Image 01
profile-image

rhasselbaum

Rob Hasselbaum
Network
Plasma 4 Widgets
test
Socket Sentry

Network 39 comments

Score 67.1%
Aug 01 2010
Other projects have kept me busy so I haven't updated the build for newer distro versions. But I see you posted a message on the openSUSE forums and got an answer there, so that's good.

http://forums.opensuse.org/forums/english/get-technical-help-here/applications/471816-socket-sentry-wont-make-12-1-a.html

As I mentioned on that thread, I welcome any patches to update the build. Otherwise, I hope to update it myself when time permits. - Jan 30 2012
It looks like you may be trying to mix a 32-bit and 64-bit build. Please delete the "build" directory and try again. If it still doesn't work, let me know. Or better yet, open a new issue at https://code.google.com/p/socket-sentry/issues/list.

As soon as I get a free weekend, I will be putting out a new release with packaging for Natty and openSUSE 11.4. - May 12 2011
Instead of "kde-devel", try installing the "kdelibs5-dev" package. I think this will resolve your build issue. Unfortunately, I don't have KDE 4.6 installation on Kubuntu to test this.

The GMock/GTest warning you see can be safely ignored. Those are only needed to run the unit tests. - Mar 15 2011
I am planning to update binary packages for both Ubuntu and openSUSE once Natty is released next month. Are you getting an error when you build under KDE 4.6? If so, it will help me if you could log a bug with details at:

https://code.google.com/p/socket-sentry/issues/list

Thanks. - Mar 14 2011
The problem appears to be fixed. Try again now. - Sep 25 2010
There is discussion today on the OBS mailing list about this issue. Apparently, it is affecting multiple projects. I will keep monitoring the situation. In the meantime, installing from source is another option. There are build instructions for openSUSE included in the source tarball. - Sep 24 2010
The service does not start until you use the Plasmoid. And if you remove all instances of the Plasmoid, the service goes to sleep after 30 seconds or so. - Sep 24 2010
Not sure why openSUSE Build Service is failing all of a sudden. Might be a transient problem on their side, but I'll look into it. Thanks for the heads-up. - Sep 24 2010
Sorry for the inconvenience. I have opened a new issue and will try to reproduce it locally. You can track the progress here: http://code.google.com/p/socket-sentry/issues/detail?id=13 - Aug 01 2010
Strange because others have reported success with Fedora. The makefile places the libsocketsent-client-common library in the same location as libpcap. Where is libpcap located on your machine?

Try rebooting, and if that doesn't work, try moving it to lib64. - Aug 01 2010
Yes, the missing tooltip is a problem in KDE 4.4.2 (and possibly earlier 4.4.x releases). You can track the bug report here: http://code.google.com/p/socket-sentry/issues/detail?id=9. I hope to have this fixed in the next release. - Apr 06 2010
Also, one minor correction: The homepage URL is actually http://code.google.com/p/socket-sentry (or, if you prefer, http://socket-sentry.googlecode.com). - Apr 01 2010
Thanks! Would you mind posting this to the forum? The address is here:

http://groups.google.com/group/socket-sentry - Apr 01 2010
Yup, someone else reported this, too, and I've opened a bug to track it: http://code.google.com/p/socket-sentry/issues/detail?id=2

Should be fixed in the next release. - Mar 30 2010
Socket Sentry

Plasma 4 Widgets 56 comments

Score 70.0%
Aug 01 2010
Looks nice. Although you might suffer some performance degradation because of the transparency. I'd be curious to know one way or the other. - Aug 05 2010
You must have the libpcap development files installed on your system in order to build Socket Sentry. - Aug 04 2010
Are you attempting to install from the DEB packages? Those are only tested on Kubuntu, and at the moment, the same DEB package supports both Karmic and Lucid. For Debian, I would recommend building from source. - Aug 03 2010
Socket Sentry gets its color palette from the current Plasma theme, not from the windows color scheme. Unfortunately, not all themes work equally well. Try a different theme like Oxygen, Air, Aya, Elegance, Glassified, etc. - Aug 02 2010
Hi roignac. Please note that the existing project repository works with Lucid, too. Instructions at http://code.google.com/p/socket-sentry/wiki/GetSoftware have details.

A separate Lucid repository is coming soon, although the only difference will be in the "branding". All code and dependencies are unchanged from Karmic. Thanks. - May 04 2010
Or, more likely, this is the case with all compiled Plasmoids. Script-based ones might not require a Plasma restart. - Apr 08 2010
This is the case with all Plasmoids AFAIK. Once a widget's library has been loaded once in the current session, you need to restart Plasma in order for changes to it to take effect. (It's not usually necessary to restart all of KDE, though.) - Apr 08 2010
If you're upgrading, you will need to restart Plasma to activate the new version of the widget. You can do this by logging out and logging back in. - Apr 08 2010
Hi Krog. Sorry, you ran into this. This is a known bug in v0.9.1 and is already fixed in the latest code. You can grab a copy from http://code.google.com/p/socket-sentry/source/checkout or wait until v0.9.2 comes out, which should happen this week. The bug occurs when IPv6 is disabled on the host. - Apr 05 2010
Hi Phobeus. One or two others have also asked for the ability to filter by program. I've added an enhancement request that you can track here: http://code.google.com/p/socket-sentry/issues/detail?id=8

Note that you already have the ability in the current release to "collapse" multiple connections into one row in the Local Settings dialog. You can show just one row per program and host, for example. Also, if you want to exclude connections to certain ports or hosts, you can do that by adding a custom filter in the Global Settings dialog. But yes, filtering by program would be nice, too. - Apr 03 2010
Nice, thank you! Could you please post this on the forum so more people might see it? Forum is located at: http://groups.google.com/group/socket-sentry - Apr 02 2010
Judging by the error, there seems to be an incompatibility between the version of KDE/Plasma you built against and the version you're trying to run it under. (Maybe the build version is newer?) It's been tested successfully on KDE 4.4.1 under Kubuntu. You might try posting on the forum (link at top) to see if other Fedora users share this problem. (I have not heard anyone else say so.) - Mar 31 2010
OK, sorry, I thought "any" would be present on all modern kernels and versions of libpcap, but I guess not. I will make it default to something else if it can't find the "any" pseudo-device. Glad there is a workaround. - Mar 30 2010
You might be able to achieve this using the "custom filter" setting on the "global settings" dialog. For example, if the Privoxy server is at address 12.34.56.78, you can type "not host 12.34.56.78" into the filter and it will filter it. You can also filter by port. Or, if the Privoxy server is on localhost (127.x.x.x), you can omit all localhost traffic by picking a specific network interface device (not "any") in the "local settings" dialog.

No support for filtering by program yet, but that is something I'm thinking of adding. - Mar 30 2010
You can drop it onto a panel so it only shows up when clicked. As an added bonus, its resource utilization goes down to almost nothing when it's iconified. - Mar 30 2010
Hmm... I am surprised "any" is not available on your machine. What distro/kernel are you using? - Mar 30 2010
I will look at adding support for this. Thanks for the suggestion. - Mar 30 2010