Image 01
profile-image

ARTO222

test
KDE ePub Thumbnailer

Various Plasma 5 Improvements 51 comments

by caig
Score 82.0%
Jan 12 2018
Thanks for the reply.

I'm on ubuntu/kubuntu 17.10.

I still cannot get this to compile & install. (Dolphin Version 17.04.3) Can you list all dependencies?

Latest errors:
-- Found KF5KIO: /usr/lib/x86_64-linux-gnu/cmake/KF5KIO/KF5KIOConfig.cmake (found version "5.38.0")
-- Could NOT find KF5Archive (missing: KF5Archive_DIR)
-- Could NOT find KF5Archive: found neither KF5ArchiveConfig.cmake nor kf5archive-config.cmake
CMake Error at /usr/share/cmake-3.9/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Could NOT find KF5 (missing: Archive) (found version "5.38.0")
Call Stack (most recent call first):
/usr/share/cmake-3.9/Modules/FindPackageHandleStandardArgs.cmake:377 (_FPHSA_FAILURE_MESSAGE)
/usr/share/ECM/find-modules/FindKF5.cmake:110 (find_package_handle_standard_args)
CMakeLists.txt:15 (find_package)


-- Configuring incomplete, errors occurred!
---------------------------
I got this far by googling the errors and installing suggested packages. But I can't get past this one.
Thanks, again - Nov 07 2017
Same issue on a fresh on manjaro. - Sep 17 2016
Thanks for the terrific job.
Installed following the Installation from source (KF5) instructions on your github page on manjaro 16.06.1 and everything works.

However, on both on linux mint 18 as well as kubuntu 16.04 terminal output is:
--------------------
mint@mint ~/bin/kde-thumbnailer-epub-1.1/build $ cmake -DKDE_INSTALL_USE_QT_SYS_PATHS=ON -DCMAKE_INSTALL_PREFIX=`kf5-config --prefix` ..
-- The C compiler identification is GNU 5.4.0
-- The CXX compiler identification is GNU 5.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:5 (find_package):
Could not find a package configuration file provided by "ECM" (requested
version 1.0.0) with any of the following names:

ECMConfig.cmake
ecm-config.cmake

Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
to a directory containing one of the above files. If "ECM" provides a
separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/home/mint/bin/kde-thumbnailer-epub-1.1/build/CMakeFiles/CMakeOutput.log".
------------
Would much appreciate any suggestions on this as well as the build instructions for the .mobi thumbnailer you mentioned in a previous post.

Thanks again. - Sep 16 2016