Vista Start Menu for Gnome Panel

Various Gnome Stuff

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
5.0
Available as/for: -
Description:

An elegant and functional menu with many themes, not just vista.
Currently supported languages:
English, Czech, French, Spanish, Portuguese

THIS IS NOT COMPATIBLE WITH UBUNTU 8.10 Intrepid Ibex
The lightweight Vista Menu implementation is compatible.
http://www.gtk-apps.org/content/show.php/XP+Start+Menu?content=93807

I may work on this in future, but if any python programmers out there want to take this over and improve it, please email me for the latest source.

INSTALLATION

-Install Dependencies:

sudo apt-get install python2.5 python-xdg python-cairo python-gconf python-xlib deskbar


-Download package from this page
-Extract to your desktop, and double click on the installer inside
-Right click on the gnome panel, and go to 'add to panel' and select vista menu


We need people to help make new themes and translate the menu to new languages! Please send me a message if you can help.
Last changelog:

12 years ago

Beta 1.07: Includes new theme and fixes multiple program launching and command line errors
Beta 1.08: Basically a total rewrite!
Beta 1.08_1: Fixed Blue Wave theme.
Beta 1.08_2: More languages added.

Whise

13 years ago

is there a new version comming soon?

Report

michu

13 years ago

Is your menu works on Fedora 7? I tried to find python-cairo in yum but i couldn't. Do I need it so much?

I'd like to have your menu but for some reason I can't add it to the gnome panel, I get the error:
"The panel encountered a problem while loading "OAFIID:GNOME_VistaMenu".Do you want to delete the applet from your configuration?"

I've followed all the instructions and still can't get it to work.

Thanks for help...

Report

saudi-linux

13 years ago

great work

i'm using debian (unstable and also Testing)

the menu works fine but i have some problem of viewing the apps menu see the screen shot

http://saudi.unix.googlepages.com/Screenshot.png

abdullah@Joatha:~$ Vista_Menu.py run-in-window
Reorientating Orb top!! (Don't let this happen too often!!)
Reorientating Orb top!! (Don't let this happen too often!!)
Traceback (most recent call last):
File "/usr/lib/vistamenu/Vista_Menu_Object.py", line 101, in button_press
self.ShowMenu()
File "/usr/lib/vistamenu/Vista_Menu_Object.py", line 157, in ShowMenu
self.hwg.setup(origin[0], origin[1])
File "/usr/lib/vistamenu/Vista_Menu_Main.py", line 143, in setup
self.PGL.ProgramListPopulate(self.wTree.get_widget("MenuFrame"))
File "/usr/lib/vistamenu/PGMenu/0/PGMenu.py", line 19, in ProgramListPopulate
self.PopulateButtons()
File "/usr/lib/vistamenu/PGMenu/0/PGMenu.py", line 51, in PopulateButtons
self.Buttonlist.append(self.AddButton(self.XDG.L_Names[i],self.XDG.L_Icons[i],0))
File "/usr/lib/vistamenu/PGMenu/0/PGMenu.py", line 63, in AddButton
self.Pic = gtk.gdk.pixbuf_new_from_file_at_size(iconfile, Images.PG_iconsize, Images.PG_iconsize)
gobject.GError: Failed to open file '/usr/share/icons/application-default-icon.png': No such file or directory
launching item from application list...
Traceback (most recent call last):
File "/usr/lib/vistamenu/PGMenu/0/PGMenu.py", line 101, in PGListButtonClick
self.PopulateButtons()
File "/usr/lib/vistamenu/PGMenu/0/PGMenu.py", line 51, in PopulateButtons
self.Buttonlist.append(self.AddButton(self.XDG.L_Names[i],self.XDG.L_Icons[i],0))
File "/usr/lib/vistamenu/PGMenu/0/PGMenu.py", line 63, in AddButton
self.Pic = gtk.gdk.pixbuf_new_from_file_at_size(iconfile, Images.PG_iconsize, Images.PG_iconsize)
gobject.GError: Failed to open file '/usr/share/icons/application-default-icon.png': No such file or directory

Report

saudi-linux

13 years ago

i installed the Beta 1.05

and all the dependesis are installed

Report

C

qb89dragon

13 years ago

Looks like you don't have the application-default-icon.png there on the last line. You could copy a simmilar icon in its place there as a temporary fix. But im not going to be working on this menu for a while to come. New job and such.

Report

Shashwat

13 years ago

Whenever I use Show Transparent Icon .. It shows white square instead showing User Icon though I have set up the icon :(

http://www.imgx.org/pfiles/5025/Screenshot-1.png

Compiz Fusion is up and running :)

Report

swmiller6

13 years ago

I love this menu!!!
One problem I have is evolution is not working. When I click the button it starts evolution (it shows in the process manager) but never opens then after a few moments goes into zombie state?
Any ideas on how to fix this?

Report

ElTimo

13 years ago

ok so when I have a second-level submenu (i.e. a submenu inside a submenu) and i try to click on it, nothing happens. Any workarounds? Or should i get hacking? Great applet other than that! I've been looking all over for something like this!

Report

C

qb89dragon

13 years ago

To fix this the quick way before the next release, type
sudo gedit /usr/lib/vistamenu/XDG.py

and at line 254 change
self.Menu = self.Menu.getMenu(self.L_Paths[index])

to

self.Menu = self.BaseMenu.getMenu(self.L_Paths[index])

Report

dhanuka

13 years ago

Hi,

This is a great work you have done.

I have a one problem also. I installed v 1.05 using my sudo priviledged accout but menu is not loading and it is like in http://img176.imageshack.us/my.php?image=screenshot1jh7.png.

But if I logged in using root account menu works perfectly.

Can u help me please. This is a really excellent work so I don't want to lose this.

Regards
Dhanuka

Report

paul92

13 years ago

Hi, sorry for my English (I'm Belgian and I speak French)
The problem with the white menu is apparent when there is a user picture... For this, I deleted this (/home/username/.face)

Bye, I hope this problem 's going to result for the next version...

Report

dhanuka

13 years ago

Thanks paul92, it works :-)

I hope this can be fixed with next release since it worked in previous releases.

Thanks and Regards
Dhanuka

Report

Legace

13 years ago

I fixed the panel bug by deleting the GConf settings:

gconftool --set /apps/compiz/general/allscreens/options/active_plugins \
--type list --list-type string \
'[gconf,png,svg,decoration,wobbly,fade,minimize,cube,rotate,zoom,scale,move,place,switcher,screenshot,resize]'

Report

Legace

13 years ago

I installed this applications, and then uninstalled it but the panel shadows are still not there.

I use compiz fusion and the panels should have shadows below them but this program disabled them! How can I enable them again??

http://uploadpsd.com/file/19785.png (new screenshot after vista start menu install)
http://uploadpsd.com/file/19786.png (old screenshot WITH shadow)

Report

C

qb89dragon

13 years ago

Hi,
sorry to hear that it didn't fit your requirements for a menu. Any suggestions for improving it?

To remove the shadow, go to your compiz settings (ccsm), go to 'window decorator', and where it says shadow windows, change !dock to any

Report

Metallist

13 years ago

Hi guys!Have a problem with this button.At the beginning it worked well,but then something wrong,and now it's looks pretty bad.I tried to reinstall it,but no result.Please follow this link to view wat's wrong

http://img176.imageshack.us/my.php?image=screenshot1jh7.png

Can someone help me?I really like this button,and don't want to lose it =(.


Sorry for bad English.

Report

C

qb89dragon

13 years ago

Hi,
Are you running Ubuntu Hardy?
I am and have the same problem. Therefore it makes developing the menu harder, and this seems to be a bug in the underlying packages that support widget integration into the gnome panel.
The reason there has been little development on the menu in the last 2 weeks is because I have started a new job and have alot of other complications that prevent me from having all the spare time in the world that I would wish for, so hang in there, I will get around to this eventually.

Report

dot357

13 years ago

Hello, I have noticed that when a submenu have a lot of applications, not all of them shows, nor the back button.
How can solve this?
Congratulations on your work

Sorry for my english

Report

C

qb89dragon

13 years ago

This bug is new and seems to occur when the menu parser fails to load an icon that XDG thinks is there. If you can use the menu editor to change the icon of the menu item below the last one shown on a broken submenu then it will work.
I will add this as a bug and fix it in the next release.

Report

dot357

13 years ago

Thanks for responding

Report

algalord

13 years ago

Hello, thanks a lot for this incredible applet... but i have a little problem with the firefox launcher in the panel. When i launch firefox, it open as home page, this: http://www.%u.com/

¿how can i solve this??

sorry if someone has asked it before.

Thanks

Report

Faustus

13 years ago

I love the concept and I'd love to use it but for some reason I can't add it to the gnome panel, I get the error Quote:"The panel encountered a problem while loading "OAFIID:GNOME_VistaMenu".Do you want to delete the applet from your configuration?"

I'm probably just overlooking something but I've followed all the instructions in the readme and still can't get it to work.

Now if I go into /usr/lib/vistamenu and launch Start_Menu.sh or what not I can get it to show up on the screen no problems, and through that I can access the menu and such. However I can't actually get the menu to open up, i'm assuming because its not attached to the panel?

Hope to get some feedback soon, I'd love to get it working!

Report

Faustus

13 years ago

I love the concept and I'd love to use it but for some reason I can't add it to the gnome panel, I get the error Quote:"The panel encountered a problem while loading "OAFIID:GNOME_VistaMenu".Do you want to delete the applet from your configuration?"

I'm probably just overlooking something but I've followed all the instructions in the readme and still can't get it to work.

Now if I go into /usr/lib/vistamenu and launch Start_Menu.sh or what not I can get it to show up on the screen no problems, and through that I can access the menu and such. However I can't actually get the menu to open up, i'm assuming because its not attached to the panel?

Hope to get some feedback soon, I'd love to get it working!

Report

pch76

13 years ago

Reorientating Orb top!! (Don't let this happen too often!!)
Reorientating Orb top!! (Don't let this happen too often!!)
Traceback (most recent call last):
File "/usr/lib/vistamenu/Vista_Menu_Object.py", line 101, in button_press
self.ShowMenu()
File "/usr/lib/vistamenu/Vista_Menu_Object.py", line 157, in ShowMenu
self.hwg.setup(origin[0], origin[1])
File "/usr/lib/vistamenu/Vista_Menu_Main.py", line 87, in setup
self.ChangeUserPic_Normalise()
File "/usr/lib/vistamenu/Vista_Menu_Main.py", line 314, in ChangeUserPic_Normalise
self.usericon.updateimage(1,Images.UserImage)
File "/usr/lib/vistamenu/Cairo_Window.py", line 129, in updateimage
self.temp = cairo.ImageSurface.create_from_png(imagefile)
IOError: error while reading from input stream

Report

C

qb89dragon

13 years ago

What distribution are you using, and do you have python-cairo installed?

Report

12 years ago

Beta 1.07: Includes new theme and fixes multiple program launching and command line errors
Beta 1.08: Basically a total rewrite!
Beta 1.08_1: Fixed Blue Wave theme.
Beta 1.08_2: More languages added.

12345678910
Be the first to comment
File (click to download) Version Description PackagetypeArchitecture Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
beta 1.08
updated Nov 23 2008
added Dec 10 2007
downloads 24h
0
mediaviews 24h 0
pageviews 24h 1